Support Questions

Find answers, ask questions, and share your expertise

Unable to start hbase 2.4.13 after enabling atlas-hbase hook

Explorer

Hi All,

 

We are enabling hbase hook in apache atlas 2.2.0 , we followed below steps ,

https://atlas.apache.org/2.0.0/Hook-HBase.html

 

After that , when we start to start hbase , failing with below error.

ROD.
2022-09-05 14:02:23,481 INFO [master/vmazewdranger01:16000:becomeActiveMaster] atlas.ApplicationProperties: Setting solr.wait-searcher
property 'true'
2022-09-05 14:02:23,481 INFO [master/vmazewdranger01:16000:becomeActiveMaster] atlas.ApplicationProperties: Setting index.search.map-na
me property 'false'
2022-09-05 14:02:23,482 INFO [master/vmazewdranger01:16000:becomeActiveMaster] hook.AtlasHook: Failed to load application properties
org.apache.atlas.AtlasException: Failed to load application properties
at org.apache.atlas.ApplicationProperties.get(ApplicationProperties.java:150)
at org.apache.atlas.ApplicationProperties.get(ApplicationProperties.java:103)
at org.apache.atlas.hook.AtlasHook.<clinit>(AtlasHook.java:80)
at org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor.<init>(HBaseAtlasCoprocessor.java:46)

2022-09-05 14:02:23,484 ERROR [master/vmazewdranger01:16000:becomeActiveMaster] coprocessor.CoprocessorHost: The coprocessor org.apache.
atlas.hbase.hook.HBaseAtlasCoprocessor threw java.io.IOException: java.lang.InstantiationException: org.apache.atlas.hbase.hook.HBaseAtl
asCoprocessor
java.io.IOException: java.lang.InstantiationException: org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor
at org.apache.hadoop.hbase.coprocessor.CoprocessorHost.checkAndLoadInstance(CoprocessorHost.java:280)
at org.apache.hadoop.hbase.coprocessor.CoprocessorHost.loadSystemCoprocessors(CoprocessorHost.java:171)

2022-09-05 14:02:23,487 ERROR [master/vmazewdranger01:16000:becomeActiveMaster] master.HMaster: ***** ABORTING master vmazewdranger01,16
000,1662386539831: The coprocessor org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor threw java.io.IOException: java.lang.InstantiationE
xception: org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor *****
java.io.IOException: java.lang.InstantiationException: org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor

 

Thanks,

Venkat

1 ACCEPTED SOLUTION

Super Collaborator

Hello @Venkatd 

 

Thanks for using Cloudera Community. This is an Older Post, yet I am sharing a review for fellow Community Users. 

 

Based on the Post, the Service is affected owing to "org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor" issues. A Quick Solution is to use "hbase.coprocessor.abortonerror" as "false" to avoid any Co-Processor failure cause Master/RegionServer startup failure.  

 

Typically, Such issues are caused by few factors as shared below:
1. Missing "atlas.application.properties" from Atlas Configuration Directory in HBase Configuration Directory "/etc/hbase/conf".
2. The HBase-Atlas Hook being disabled.
3. Ensure "org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor" is present in the Co-Processor Classes ("hbase.coprocessor.<master|region>.classes"). 


The Missing "atlas.application.properties" file is the Most-Likely Cause. 

 

Regards, Smarak

View solution in original post

2 REPLIES 2

Super Collaborator

Hello @Venkatd 

 

Thanks for using Cloudera Community. This is an Older Post, yet I am sharing a review for fellow Community Users. 

 

Based on the Post, the Service is affected owing to "org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor" issues. A Quick Solution is to use "hbase.coprocessor.abortonerror" as "false" to avoid any Co-Processor failure cause Master/RegionServer startup failure.  

 

Typically, Such issues are caused by few factors as shared below:
1. Missing "atlas.application.properties" from Atlas Configuration Directory in HBase Configuration Directory "/etc/hbase/conf".
2. The HBase-Atlas Hook being disabled.
3. Ensure "org.apache.atlas.hbase.hook.HBaseAtlasCoprocessor" is present in the Co-Processor Classes ("hbase.coprocessor.<master|region>.classes"). 


The Missing "atlas.application.properties" file is the Most-Likely Cause. 

 

Regards, Smarak

Super Collaborator

Hello @Venkatd 

 

Since this is an Old Post & we have shared a few Action Plan with missing "atlas.application.properties" from Atlas Configuration Directory in HBase Configuration Directory "/etc/hbase/conf" being the Most-Likely reason for the concerned failure along with Steps to mitigate the HMaster/RegionServer failure (By setting "hbase.coprocessor.abortonerror" as "false") to avoid any Co-Processor failure cause Master/RegionServer startup failure, We shall mark the Post as Solved now. 

 

Thank You for using Cloudera Community. 

 

Regards, Smarak

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.