Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Unable to start the Hive2 Interactive Server

avatar
Contributor

I have recently upgraded HDP 2.5 and enabled Interactive Query for LLAP. I am trying to start the Hive2 Interactive query on my 4-node cluster and it fails.giving the below error.

Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_interactive.py", line 512, in check_llap_app_status status = do_retries() File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/decorator.py", line 55, in wrapper return function(*args, **kwargs) File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_interactive.py", line 501, in do_retries llap_app_info['desiredInstances'])) Fail: App state is RUNNING_PARTIAL. Live Instances : '3', Desired Instance : '4' 2017-03-16 17:00:40,921 - LLAP app 'llap0' deployment unsuccessful. Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_interactive.py", line 535, in <module> HiveServerInteractive().execute() File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute method(env) File "/var/lib/ambari-agent/cache/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_interactive.py", line 123, in start raise Fail("Skipping START of Hive Server Interactive since LLAP app couldn't be STARTED.") resource_management.core.exceptions.Fail: Skipping START of Hive Server Interactive since LLAP app couldn't be STARTED. ~

1 ACCEPTED SOLUTION

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
5 REPLIES 5

avatar
Super Guru

@viswanath kammula

The traceback shows maybe a symptom. Best place to start are the hiverserver2 logs and grep for errors. Most likely, your LLAP settings may not be appropriate, but until you mine the logs, that is just an assumption. Please provide excerpt from logs that indicate an error at the same timestamp.

avatar
Rising Star
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

I fixed it. I am having 4 nodes and trying to run 4 daemons, But I set the daemon container size to its full memory. This does not give any space for application manager to run on any node. Or If application manager runs on a node, One of the daemon which is supposed to run on that node does not get its full container memory which it was set to.

avatar
New Contributor

Hi, you have to leave memory for default in (yarn queue manager -> default)

14801-default-memory.png

avatar
Contributor

I am also facing the same issue in HDP3... Is it resolved...????