Support Questions
Find answers, ask questions, and share your expertise

Using Python <2.7.9 with HDP 2.4

Solved Go to solution

Using Python <2.7.9 with HDP 2.4

Hi All,

The documentation says Python 2.6 is required but then right below it says:

"Python v2.7.9 or later is not supported due to changes in how Python performs certificate validation."

Does that mean you can use Python 2.7.X so long as it's less than 2.7.9?

Thanks,

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Using Python <2.7.9 with HDP 2.4

Okay got the answer:

For CentOS 6 and SLES 11: Hortonworks supporst Python 2.6.* (which is what is installed by default). Hortnworks do not support switching to Python 2.7.* on these OSs.

For all other supported OSs (CentOS 7, Ubuntu 12 + 14, Debian 7): Hortonworks support Python 2.7.* (which is what is installed by default). As of Ambari 2.2, there is no longer an issue with 2.7.9 (therefore, you can use 2.7.*).

View solution in original post

4 REPLIES 4

Re: Using Python <2.7.9 with HDP 2.4

@Andrew Watson

Yes. Python 2.6 is the minimum requirement.

Re: Using Python <2.7.9 with HDP 2.4

@vpoornalingam Okay and to confirm, python 2.7.8 is the highest version allowed?

Re: Using Python <2.7.9 with HDP 2.4

New Contributor

can we install python 2.7 or later on current running HDP2.4.2 secure cluster, with out breaking any components?

Re: Using Python <2.7.9 with HDP 2.4

Okay got the answer:

For CentOS 6 and SLES 11: Hortonworks supporst Python 2.6.* (which is what is installed by default). Hortnworks do not support switching to Python 2.7.* on these OSs.

For all other supported OSs (CentOS 7, Ubuntu 12 + 14, Debian 7): Hortonworks support Python 2.7.* (which is what is installed by default). As of Ambari 2.2, there is no longer an issue with 2.7.9 (therefore, you can use 2.7.*).

View solution in original post