Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Using Python <2.7.9 with HDP 2.4

avatar

Hi All,

The documentation says Python 2.6 is required but then right below it says:

"Python v2.7.9 or later is not supported due to changes in how Python performs certificate validation."

Does that mean you can use Python 2.7.X so long as it's less than 2.7.9?

Thanks,

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
4 REPLIES 4

avatar
@Andrew Watson

Yes. Python 2.6 is the minimum requirement.

avatar

@vpoornalingam Okay and to confirm, python 2.7.8 is the highest version allowed?

avatar
New Contributor

can we install python 2.7 or later on current running HDP2.4.2 secure cluster, with out breaking any components?

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login