Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

WIth HDP3.1 facing issue with hive insert statements


Screenshot from 2022-06-17 15-36-35.png

Hello Everyone,

Greeting of the day. 


I have installed HDP 3.1 two times on two different servers. That is it was a single node installation on two different physical machines. But both the times I am facing issues in hive. In this , create,update, drop, delete queries works properly but always at the time of insert statement it waits for long time with a message "tez session hasn't been created yet, opening session". And it further doesn't progress . So I have to wait for some time and then cancel the command/queries.

Normal basic insert statements also doesn't works and gets same message. 
 I have tried all possible tuning parameters in hive, yarn, tez etc but no luck. Tried with set session variables as well i.e  hive.execution.engine but no luck again.


Need your help, valuable suggestions/inputs here.Thank you.

Thanks & Regards,


Master Collaborator

Hi @dmharshit, if possible can you try running the insert query after changing the execution engine to MapReduce by setting the below parameter?

set hive.execution.engine=mr; 


Hi @jagadeesan Tried this option already with set but no luck

Master Collaborator

Hi @dmharshit, once you have set hive.execution.engine=mr; what error are you getting? Please can you attach the screenshot? 



It further proceeds with starting job and get urls but jobs doesn't get complete and remains in hang state.

Expert Contributor


Yarn queue where the Tez application gets submitted don't have enough capacity to start a new application.


You should be able to see tez application in yarn rm -> accepted applications. Tune NM capacity + reduce following configs to let yarn accept & launch new application.

-- Setting AM size to 512mb


-- Setting Task container size to 512mb

set hive.tez.container.size=512;