Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Why Hive Compaction is failing ?

avatar
Super Collaborator

Hi Everyone,
We have enabled hive compaction on transnational table in order to improve fetch query performance.Somehow it's not working at my end, am facing attached error which i observed in "hivemetastore.log". 

Can somebody please let us know, How this issue can be resolved ? 

Screenshot (194).png

1 ACCEPTED SOLUTION

avatar
Super Guru

I think error log is pretty informative, getGroups call for $Superuser does not get any group associated with the user, you might need to run "hdfs groups" command on the HMS node for this user if that the case and fix the env issue.

View solution in original post

2 REPLIES 2

avatar
Super Guru

I think error log is pretty informative, getGroups call for $Superuser does not get any group associated with the user, you might need to run "hdfs groups" command on the HMS node for this user if that the case and fix the env issue.

avatar
Super Collaborator

Accidently , I marked this answer as resolved . 
@rajkumar_singh 

I am getting below output after executing "hdfs groups <username>" command.

 

<username>@<kerberose principle > : domain users dev_sudo

 

As i am not much aware of cluster configuration 

So , Could you please help me to understand the output of this command.