Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Why do I have "incompatible Parquet schema" error after changing a column type from double to string ?

avatar
Explorer

File 'hdfs://xxx:8020/data/hive/warehouse/xxxx.db/test_bak/8743abe2968ecbe7-3f9c13700000000_2053286657_dat...' has an incompatible Parquet schema for column 'xxxx.test_bak.ordered_revenue'. Column type: STRING, Parquet schema: optional double ordered_revenue [i:20 d:1 r:0]

 

I made this change in Hue.

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Hello

 

The table column type must match the columnar file format of the Parquet file, else you will result in the error you got

 

One way if you prefer to use string instead of double for that data attribute, you can recreate the parquet file with the column type of string

View solution in original post

1 REPLY 1

avatar
Expert Contributor

Hello

 

The table column type must match the columnar file format of the Parquet file, else you will result in the error you got

 

One way if you prefer to use string instead of double for that data attribute, you can recreate the parquet file with the column type of string