Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Why output port not redirecting the flowfiles to next process group?

avatar
Super Collaborator

Hi   All,

 

I have used three process groups in nifi (pg1,pg2,pg3). There is an output port called as pg1_Out coming out from pg1. This port is connected to pg2_in and pg3_in input ports.

 

pg1_out------>pg2_in

  |

  |

  |

pg3_in

 

Problem : when i trigger these process groups then flowfiles are passing to only pg3_in but not to pg2_in. Ideally , the flow files should get passed to both input port.

I do not understand why am i seeing such behaviour in nifi.

 

Does anyone has faced such problem before? Please respose to me your thoughts on this. I would be really appreciated to your help.

 

 

1 ACCEPTED SOLUTION

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
2 REPLIES 2

avatar
Super Mentor

@Manus 

 

I have never seen this.  Anytime a relationship is defined in more than one connection, the originating FlowFile will be routed to one connection and clone routed to the other(s).

Perhaps you can share a some screenshots of your dataflow showing the behavior you are seeing?
Screenshot of flow feeding the output port inside PG1.
Screenshot of tope level interconnected Process group PG1, PG2, and PG3.

 

Is the input port inside PG2 connected to anything?

 

What version of NiFi are you using?

 

Thank you,

Matt

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login