Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Zeppelin UI Hangs

Solved Go to solution
Highlighted

Zeppelin UI Hangs

New Contributor

I have a very dataset returned from sparksql, but only three columns. When I used the scatter plot option zeppelin hangs with the spinning pinwheel. It is clearly running as my laptop CPU is high and drives the fan on. Is there any way to kill off this long running process or remove the paragraph from my notebook?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Zeppelin UI Hangs

Expert Contributor
@Doug Reid

You can use zeppelin api to delete the paragraph. usage is present on https://zeppelin.apache.org/docs/0.6.1/rest-api/rest-notebook.html#delete-a-paragraph

5 REPLIES 5

Re: Zeppelin UI Hangs

Expert Contributor
@Doug Reid

You can use zeppelin api to delete the paragraph. usage is present on https://zeppelin.apache.org/docs/0.6.1/rest-api/rest-notebook.html#delete-a-paragraph

Re: Zeppelin UI Hangs

New Contributor

My hack was to find the JSON file for the notebook and delete the paragraph from there. This worked, but your method is much cleaner

Re: Zeppelin UI Hangs

Guru

By default, zeppelin.spark.maxResult is set to 1000 which means that Spark SQL will result only a total of 1000 results regardless of the size of the dataset.

If your notebook hangs, then you should restart the zeppelin service from Ambari. You can then navigate to your notebook and delete the paragraph manually.

Re: Zeppelin UI Hangs

New Contributor

Restarting the service didn't make a difference. Once available and then opening the notebook, the paragraph still was trying to render the scatter graph and hung.

Re: Zeppelin UI Hangs

New Contributor

Last occurence of this issue happened to require a clearing of the outputs of the notes.

I was working on a note including a display job that took ages and the progress bar froze. I restarted zeppelin, Spark, Yarn, nothing seemed to fix it. The note seemed "lost", undisplayable, desperately blank.

My fix (after a couple of hours trying to figure what the hell was causing that) was to Hover over the note in the welcome page, and click the rubber, "clear output"... and voila,I was able to open my note again. Note That this has to be done after a restart of the Zeppelin service.

Hope this helps