Support Questions
Find answers, ask questions, and share your expertise

Zeppelin authentication HDP 2.3.0

Solved Go to solution

Zeppelin authentication HDP 2.3.0

Expert Contributor

Hi,

My cluster is not Kerberized. I am using HDP 2.3.0 with Ambari 2.1.1. I updated Spark to 1.6.0 (from HDP 2.4 stack) and installed Zeppelin from this tutorial.

I have a problem with authentication. When I set zeppelin.anonymous.allowed to false in Ambari, and restart Zeppelin I can still access Zeppelin without providing credentials. Also I want to configure authentication via Active Directory but I can't find shiro.ini file. Zeppelin is installed in /opt/zeppelin. My questions are:

1. Is AD or any authentication method supported for Zeppelin for components versions in my case?

2. Is AD authentication supported in HDP 2.3.2?

3. Does Zeppelin works with Spark version 1.3.1?

4. Why I can't see shiro.ini in conf directory?

Whats strange: In Ambari -> Add services I see Zeppelin Notebook in version 0.0.10

Thank you in advance!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Zeppelin authentication HDP 2.3.0

Super Guru

@Edgar Daeds LDAP+AD integration for authentication should be in zeppelin 0.6.0. I believe it is for HDP 2.5

View solution in original post

5 REPLIES 5

Re: Zeppelin authentication HDP 2.3.0

Super Guru

@Edgar Daeds LDAP+AD integration for authentication should be in zeppelin 0.6.0. I believe it is for HDP 2.5

View solution in original post

Re: Zeppelin authentication HDP 2.3.0

Expert Contributor
@Sunile Manjee

I installed zeppelin-0.6.0-incubating-SNAPSHOT.tar.gz tarball. As I read LDAP authentication is currently available for HDP version 2.4 source

Re: Zeppelin authentication HDP 2.3.0

Super Guru

it is in technical preview in 2.4x. Your question was about 2.3.2. So you should be okay testing it out in 2.4.x

Re: Zeppelin authentication HDP 2.3.0

Expert Contributor

@Sunile Manjee Thank you for answer. So there is no way to authenticate Zeppelin via LDAP+AD in HDP stack 2.3.0 or 2.3.2? And that is why I can't see shiro.ini in my conf folder?

Re: Zeppelin authentication HDP 2.3.0

Super Guru

@Edgar Daeds I do not recommend using Zeppelin LDAP+AD (0.6.0) on stack less then 2.4.x. Can it be done..I can't say for sure. Your path may be riddled with trouble. Do it with 2.4.x.