Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Zeppelin livy not working with connection refused error


We have a kerberized cluster with AD integrated and I am getting this error. Connection refused at Method) at at at at at at at org.apache.zeppelin.interpreter.remote.ClientFactory.create( at org.apache.zeppelin.interpreter.remote.ClientFactory.create( at org.apache.commons.pool2.BasePooledObjectFactory.makeObject( at org.apache.commons.pool2.impl.GenericObjectPool.create( at org.apache.commons.pool2.impl.GenericObjectPool.borrowObject( at org.apache.commons.pool2.impl.GenericObjectPool.borrowObject( at org.apache.zeppelin.interpreter.remote.RemoteInterpreterProcess.getClient( at org.apache.zeppelin.interpreter.remote.RemoteInterpreter.init( at org.apache.zeppelin.interpreter.remote.RemoteInterpreter.getFormType( at org.apache.zeppelin.interpreter.LazyOpenInterpreter.getFormType( at org.apache.zeppelin.notebook.Paragraph.jobRun( at at org.apache.zeppelin.scheduler.RemoteScheduler$ at java.util.concurrent.Executors$ at at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( at java.util.concurrent.ScheduledThreadPoolExecutor$ at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at

Also I have tried all other solutions present on this community



@Bhavin Tandel, are you using HDP cluster? Can you please check if you have followed steps mentioned in below article?


Hey @yvora yup, I did follow that but error still persist.


@Bhavin Tandel, when are you hitting this errors? can you please explain the steps which lead to this error?


Sorry for late reply, i am again getting the same issue. It is just sc.version

@Bhavin Tandel What exception do you see in livy server logs ?


Actually the home folder for zeppelin-principal was not present and after doing the need. We tried `livy.pyspark` and it asked us to push hive-site.xml file to spark-client/conf folder on all datanodes.

And then it worked but then now again it stopped

with the following error

Error running rest call; nested exception is org.springframework.web.client.HttpClientErrorException: 413 Request Entity Too Large

Super Collaborator
@Bhavin Tandel

Add below two properties to livy-conf from ambari and see if it fix 413 error

livy.http.request.header.size and livy.http.response.header.size to 131072 in livy-conf


well i couldn't figure out the issue with the server but it was up and running the next day without the need to do any change.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.