Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Zookeeper not starting

avatar
Contributor

\ZooKeeper Server Process Connection failed: Expected response imok, Actual response ruok is not executed because it is not in the whitelist. to XXXXXXXXXXX:2181 when i start zookeeper on ambari its successfully stated but service is stopped immediately. its showing above error /

1 ACCEPTED SOLUTION

avatar
Master Mentor

@Manoj690 

It's always a good idea to share the HDP and Zk version plus the zk logs in /var/log/* having said that can you share your zoo.cfg ?
If you really need enable all four letter word commands by default, you can use the asterisk option so you don't have to include every command one by one in the list.See below

4lw.commands.whitelist=*

As you have not shared your logs that's a starting point, then restart your zookeeper and let me know!

View solution in original post

1 REPLY 1

avatar
Master Mentor

@Manoj690 

It's always a good idea to share the HDP and Zk version plus the zk logs in /var/log/* having said that can you share your zoo.cfg ?
If you really need enable all four letter word commands by default, you can use the asterisk option so you don't have to include every command one by one in the list.See below

4lw.commands.whitelist=*

As you have not shared your logs that's a starting point, then restart your zookeeper and let me know!