Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

after reboot unable to start yarn

avatar
Explorer

After reboot clutser hadoop, a few services like yarn don't start anymore with the following message :

 

resource_management.libraries.providers.hdfs_resource.WebHDFSCallException: Execution of 'curl -sS -L -w '%{http_code}' -X GET 'http://hostname:50070/webhdfs/v1/ats/done?op=GETFILESTATUS&user.name=hdfs'' returned status_code=401. 
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
<title>Error 401 Authentication required</title>
</head>
<body><h2>HTTP ERROR 401</h2>
<p>Problem accessing /webhdfs/v1/ats/done. Reason:
<pre>    Authentication required</pre></p><hr /><i><small>Powered by Jetty://</small></i><br/>                                                
<br/> 

Any idea ?
Thanks
1 ACCEPTED SOLUTION

avatar
Master Collaborator

Possible solution: 

1. Recreate Keytabs
2. Start Yarn from CLI and fix Ambari issue
https://docs.cloudera.com/HDPDocuments/HDP2/HDP-2.6.2/bk_command-line-upgrade/content/start-yarn-mr-...

 Kindly provide the below output for further investigation.

curl -sS -L -w '%{http_code}' -X GET -d '' -H 'Content-Length: 0' --negotiate -u : 'http://hostname:50070/webhdfs/v1/ats/done?op=GETFILESTATUS

 

View solution in original post

1 REPLY 1

avatar
Master Collaborator

Possible solution: 

1. Recreate Keytabs
2. Start Yarn from CLI and fix Ambari issue
https://docs.cloudera.com/HDPDocuments/HDP2/HDP-2.6.2/bk_command-line-upgrade/content/start-yarn-mr-...

 Kindly provide the below output for further investigation.

curl -sS -L -w '%{http_code}' -X GET -d '' -H 'Content-Length: 0' --negotiate -u : 'http://hostname:50070/webhdfs/v1/ats/done?op=GETFILESTATUS