Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-28-2019 09:31 AM - edited 09-16-2022 07:28 AM
Hi dear Community,
When I want to connect hive with beeline I get this error. Could you help me please.
Thanks in advance.
[hive@bdhost008 bin]$ beeline -u "jdbc:hive2://bdhost008:10000/default;principal=hive/[email protected]"
WARNING: Use "yarn jar" to launch YARN applications.
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/opt/cloudera/parcels/CDH-6.2.0-1.cdh6.2.0.p0.967373/jars/log4j-slf4j-impl-2.8.2.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/opt/cloudera/parcels/CDH-6.2.0-1.cdh6.2.0.p0.967373/jars/slf4j-log4j12-1.7.25.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.apache.logging.slf4j.Log4jLoggerFactory]
Connecting to jdbc:hive2://bdhost008:10000/default;principal=hive/[email protected]
19/06/28 20:16:45 [main]: WARN jdbc.HiveConnection: Failed to connect to bdhost008:10000
Error: Could not open client transport with JDBC Uri: jdbc:hive2://bdhost008:10000/default;principal=hive/[email protected]: Failed to open new session: java.lang.IllegalArgumentException: Cannot modify hive.query.redaction.rules at runtime. It is not in list of params that are allowed to be modified at runtime (state=08S01,code=0)
Beeline version 2.1.1-cdh6.2.0 by Apache Hive
beeline>
Created 07-10-2019 04:37 AM
Hi,
Try to not put /default at the end of connection string, because it looks that your user cannot switch to default database during connection.
Regards,
Bart
Created 07-10-2019 04:48 PM
Created 07-10-2019 04:37 AM
Hi,
Try to not put /default at the end of connection string, because it looks that your user cannot switch to default database during connection.
Regards,
Bart
Created 07-10-2019 04:48 PM