Support Questions

Find answers, ask questions, and share your expertise

connection refused - AWS (HDPCD practice exam) : getting this error eventhouth i restarted ambari-agent


Hi there,

I'm trying to work with AWS for HDPCD practice exam. I ran " hdfs dfs -ls / " cmd on the terminal and getting " connection refused error". I could see all the services are not running and displays with red colour rectangle icon. I ran the below command

ssh root@namenode

password: hadoop

service ambari-agent restart



but, no services are running except Zookeeper and Ganglia services. Please let me know to solve this issue. Thanks! @rich



If you startup one of our practice exams and the cluster services are not running, here are some things to try first:

1. Run the script. You can watch the progress of this script in Ambari - it uses the Ambari REST API to start all HDP services.

2. Login to Ambari and try to start services that way

3. Restart the ambari-agent process on each node in the cluster (password for root is hadoop), then run again:

ssh root@namenode "ambari-agent restart"
ssh root@resourcemanager "ambari-agent restart"   # This only applies the HDPCA exam
ssh root@hiveserver "ambari-agent restart"	# This only applies to the HDPCA exam

If none of the steps above fix the issue, then it is likely an issue with the Docker containers not starting properly. Since you do not have root access on your practice exam, the quickest solution is to simply terminate your EC2 instance and startup another one.


View solution in original post


New Contributor

I am using us-west-2c. Will this be a issue?


I don't know, but try a different a region and see if you have any success.

New Contributor

my region is N virginia and public ip is


Did you try this:

ssh root@namenode "ambari-agent restart"

New Contributor

yes I executed the command

The log files indicate same error on host


Try this:

1. Run /home/horton/

2. Wait 5 minutes

3. If Hadoop services are not started after 5 minutes, terminate your EC2 instance and create a new one because something failed in your VM

New Contributor

it works now.. thanks for all your help

New Contributor

It worked for me by restarting the ambari service. But as Rich suggested we need to wait for 5 mins to get all service restarted. Thanks Rich.

New Contributor

Hello, can someone tell me how to scp to the practice EC2, copy my notes to my local before I terminate the instance.

I use the Public DNS:22, and chose the key file, but it still prompts me the user name and password, i tried U: horton and P: hadoop, cannot pass the authentication.

New Contributor


I wanted to take HDPCD exam . .tried logging in AWS. but when i do hadoop fs -ls .. it throws connection refused. few times. Tried recreating the instance .. still the same error.. tried starting all the services individually in ambari ... still the same error. The above root@hostname isn't working. Can you pl help ASAP? i am planning to take the exam this week

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.