Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

copy paste option not working on terminal

copy paste option not working on terminal

New Contributor

Hi everybody,

 

Maybe my question is very basic but I'm not able to figure out how to solve it. When I tried to run the exercice 1 from the tutorial I realised that the copy and paste options from the terminal are disabled (some others options from the search and terminal tabs are not working also). Some can help me to fix this problem ?

 

Thanks in Advance.

 

8 REPLIES 8

Re: copy paste option not working on terminal

Master Collaborator
The keyboard shortcuts for copy / paste in the terminal are Ctrl + Shift +
C and Ctrl + Shift + V (respectively). Have you tried those? They're not
supposed to be disabled...

Re: copy paste option not working on terminal

New Contributor

Hi,

 

I tried Ctrl + Shift + C and Ctrl + Shift + V and nothing.

 

I don't know if this have any relation but when I installed the VM on my Windos 10 was reported the capute of the the keyboard and mouse. I don't exactly what it means.

 

Do you think that I need to reinstall the VM?

 

Thaks in advance for your help.

 

 

Re: copy paste option not working on terminal

Master Collaborator
The message referring to keyboard / mouse capture simply means that moving
the focus from your host desktop to the virtual machine will not happen
seamlessly. When you click in the VM, it locks your mouse cursor inside it,
and you have to press a special key combination to move the mouse cursor
back out. Sometimes it's possible to configure the VM so that the mouse can
just move freely in and out. It shouldn't affect copy / paste.

Can you be very specific about where you're copying and pasting to? It's
unclear whether your talking about copying from the web browser, or pasting
into the terminal, or what. If you can narrow down exactly what part of
that is failing, that would help. Another factor is if you're trying to
copy something from your host to the VM and vice-versa. That usually
requires special set up to work, and the specific depend on what platform
you're using (VMware, VirtualBox, etc.)

Re: copy paste option not working on terminal

New Contributor

Dear Sean,

 

Thanks for your explanaition.

 

I don't know what happened but now it works. I was trying to use the copy bottom from tutorial exercice 1 into the terminal of quickstart-vm-5.4.2-0.virtualbox. It seems that when I clicked on the botton actually it did not copy. This time a box poped up asked me to allow the process (I think). After that the option paste was able on the terminal.

 

Just to do other test,  I tried to copy a command from my local host into the terminal, I used Ctrl + Shift + C, Ctrl + C and right botton + paste, and again the paste option was disable.

 

I guess that there is something that I missig.

 

Thanks again for your help.

Re: copy paste option not working on terminal

New Contributor

Hi Sean

 

I've just realised that the problem is my computer and not the VM. Actually since I installed the VM my laptop is very slow. I suppose because I have only 6 GB RAM.

 

Anyway I will try to continue to explore the fabulus VM.

 

Kind regards.

Chene

 

 

 

 

Highlighted

Re: copy paste option not working on terminal

New Contributor

Click on Oracel VM Setting icon 

In General Tab Go to Advanced

Select share Clipboard Bidirectional.

Re: copy paste option not working on terminal

Explorer
Big thanks for this!

select Share Clipboard Bidirectional on the Cloudera Quickstart VM 5.4.2 - Not found!

New Contributor

Hi,

 

I am looking for select Share Clipboard Bidirectional on the Cloudera Quickstart VM 5.4.2 but I can not find it.

 

Can you point me to it?

 

Thanks,

 

Hugo

Don't have an account?
Coming from Hortonworks? Activate your account here