Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

dbeaver - Impala JBC with Kerberos

avatar
Explorer

Hello Team,

We are looking for a solution or steps to implementing of impala jdbc connections in dbeaver through Kerberos.

 

No LoginModules configured for Client

Error log;

ep 19 13:02:51.421 ERROR 59 com.cloudera.impala.exceptions.ExceptionConverter.toSQLException: [Cloudera][ImpalaJDBCDriver](500166) Error creating login context using JAAS configuration: No LoginModules configured for Client.
java.sql.SQLException: [Cloudera][ImpalaJDBCDriver](500166) Error creating login context using JAAS configuration: No LoginModules configured for Client.

 

2 REPLIES 2

avatar
Expert Contributor

Hello-

See https://docs.cloudera.com/documentation/other/connectors/impala-jdbc/2-6-23/Cloudera-JDBC-Driver-for... for instructions on how to configure JAAS for JDBC. P.16, for example. Also -- just search for 'JAAS' the whole document, and follow the steps, as applicable.

 

avatar
Expert Contributor

hi @krishna2023 

according to the documentation:

https://docs.cloudera.com/documentation/other/connectors/impala-jdbc/2-6-23/Cloudera-JDBC-Driver-for...

try to create the JAAS login file and check if the connection will occur.

 

yagoaparecidoti_0-1729598712316.png