Support Questions

Find answers, ask questions, and share your expertise

hi i am working on hdp 2.3.1 with kafka 0.8.2 but i need to apply ssl on kafka so can i upgrade kafka to 0.9 without upgrading the hdp version?

 
1 ACCEPTED SOLUTION

@khushi kalra

Not advisable. One of the values of using HDP is that the different components, with their respective versions, have been thoroughly tested for interoperability. While installing newer versions is possible, their behavior has not been tested and is, thus, unsupported. It is better, and safer, to upgrade to HDP 2.3.4+ which includes Kafka 0.9.

View solution in original post

2 REPLIES 2

@khushi kalra

Not advisable. One of the values of using HDP is that the different components, with their respective versions, have been thoroughly tested for interoperability. While installing newer versions is possible, their behavior has not been tested and is, thus, unsupported. It is better, and safer, to upgrade to HDP 2.3.4+ which includes Kafka 0.9.

But what are the basic requirements for kafka 0.9 for ssl so that i can only upgrade that?

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.