Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hive-interactive and hive.server2.enable.doas

Solved Go to solution

hive-interactive and hive.server2.enable.doas

Expert Contributor

I was using hive 1 with hive.server2.enable.doas=true. Now I want to use hive-interactive, but hive.server2.enable.doas has to be false apparently (that is what ambari says). This of course makes most of my queries break because of wrong permissions.

I am curious to know

  • why this setting cannot be true
  • is there know workaround for this.

Context: hdp 2.6 with hive and hive-interactive.

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: hive-interactive and hive.server2.enable.doas

Guru
@Guillaume Roger

you can set doas to true but it's advised not to for some reasons.

For example, when setting doAs to false then HS2 is able to share resources

you're encouraged to use Ranger instead of file-based permissions (SQL permissions are available and translated to Ranger rules when activated), it's more secure and you can even set permissions to a column level.

View solution in original post

2 REPLIES 2
Highlighted

Re: hive-interactive and hive.server2.enable.doas

Guru
@Guillaume Roger

you can set doas to true but it's advised not to for some reasons.

For example, when setting doAs to false then HS2 is able to share resources

you're encouraged to use Ranger instead of file-based permissions (SQL permissions are available and translated to Ranger rules when activated), it's more secure and you can even set permissions to a column level.

View solution in original post

Highlighted

Re: hive-interactive and hive.server2.enable.doas

Explorer
Don't have an account?
Coming from Hortonworks? Activate your account here