Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 08-10-2022 05:43 AM
good morning cloudera community,
we are using apache ambari in version 2.6.2.2 and in this version we are using HDP 2.6.5, with that, we need to configure the parameter below in HDFS, but unfortunately we are not finding this option in the HDFS configuration, so we need to know how configure this parameter in HDFS?
parameter: dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS
PS: would it be in the "custom hdfs-site" option by clicking on "add property" and adding the parameter in the "properties" box?
Created 08-10-2022 07:15 AM
Hi @yagoaparecidoti ,
Yes, as you are using Ambari to manage the cluster, you can add the property as follows :
Ambari -> HDFS -> Configs -> Advanced -> Custom hdfs-site -> Add Property
dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS
Created 08-10-2022 06:27 AM
You can add these properties as additional properties in “HDFS Client Configuration Safety Valve for hdfs-site.xml”.
dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS
dfs.client.block.write.replace-datanode-on-failure.best-effort=true
If you found this response assisted with your query, please take a moment to log in and click on KUDOS 🙂 & ”Accept as Solution" below this post.
Thank you.
Created 08-10-2022 07:15 AM
Hi @yagoaparecidoti ,
Yes, as you are using Ambari to manage the cluster, you can add the property as follows :
Ambari -> HDFS -> Configs -> Advanced -> Custom hdfs-site -> Add Property
dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS