Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

how to configure fs.client.block.write.replace-datanode-on-failure.policy parameter in hdfs in ambari

avatar
Expert Contributor

good morning cloudera community,

 

we are using apache ambari in version 2.6.2.2 and in this version we are using HDP 2.6.5, with that, we need to configure the parameter below in HDFS, but unfortunately we are not finding this option in the HDFS configuration, so we need to know how configure this parameter in HDFS?

 

parameter: dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS

 

PS: would it be in the "custom hdfs-site" option by clicking on "add property" and adding the parameter in the "properties" box?

 

1 ACCEPTED SOLUTION

avatar
Super Collaborator

Hi @yagoaparecidoti ,

 

Yes, as you are using Ambari to manage the cluster, you can add the property as follows :

 

Ambari -> HDFS -> Configs -> Advanced -> Custom hdfs-site -> Add Property
dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS

View solution in original post

2 REPLIES 2

avatar
Super Collaborator

@yagoaparecidoti 

 

You can add these properties as additional properties in “HDFS Client Configuration Safety Valve for hdfs-site.xml”.


dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS
dfs.client.block.write.replace-datanode-on-failure.best-effort=true

 

If you found this response assisted with your query, please take a moment to log in and click on  KUDOS 🙂 & ”Accept as Solution" below this post.

 

Thank you.

avatar
Super Collaborator

Hi @yagoaparecidoti ,

 

Yes, as you are using Ambari to manage the cluster, you can add the property as follows :

 

Ambari -> HDFS -> Configs -> Advanced -> Custom hdfs-site -> Add Property
dfs.client.block.write.replace-datanode-on-failure.policy=ALWAYS