Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

http://localhost:50070/ is not working .

Solved Go to solution

http://localhost:50070/ is not working .

Expert Contributor

Hello ,

 

I installed HDFS using Cloudera Manager 5 . Then i tried to browse http://localhost:50070/  it was not working .

I tried running iptables -A INPUT -p tcp --dport 50070 -j ACCEPT still its not working.


Please  help .

 

Thanks

Bala

Thanks
Bala
1 ACCEPTED SOLUTION

Accepted Solutions

Re: http://localhost:50070/ is not working .

Explorer

Under your browser settings I would make sure you don't have any proxy information setup there.

15 REPLIES 15

Re: http://localhost:50070/ is not working .

Expert Contributor

Does the CM page for the HDFS service report everything as healthy?

 

Can you try browsing to the NameNode UI via the link provided on the CM page for the HDFS service?

Re: http://localhost:50070/ is not working .

Expert Contributor
Hello ,

No , Its in Concerned state.

(Red Color) 331 under replicated blocks in the cluster. 331 total blocks in the cluster. Percentage under replicated blocks: 100.00%. Critical threshold: 40.00%.

2 concerning.

Details NameNode summary: inbasdlp00958.mahindrasatyam.ad (Availability: Active, Health: Concerning). This health test reflects the health of the active NameNode.
Details Healthy DataNode: 0. Concerning DataNode: 1. Total DataNode: 1. Percent healthy: 0.00%. Percent healthy or concerning: 100.00%. Warning threshold: 95.00%.

and Where to find the link on CM page ??



Thanks
Bala

Re: http://localhost:50070/ is not working .

Expert Contributor

Which version of CM are you using?

 

In general, the link is on the HDFS service page on the top line and in the "HDFS Summary" section. 

 

On CM 5.0.2 the latter is right under the "configured capacity" display and is labeled "namenode web ui."

 

Circled in red:

 

cm_hdfs_service.jpg

 

.

Re: http://localhost:50070/ is not working .

Expert Contributor
Sorry , I didnt notice it properly . I clicked the link . I see this

" Network Access Message: The page cannot be displayed "
Thanks
Bala

Re: http://localhost:50070/ is not working .

Expert Contributor

- Can you verify that DNS works from your workstation to resolve the host that is running the namenode you're trying to look at?

- The message sounds like a firewall issue. Are you sure there isn't a firewall between you and the namenode machine preventing access?

 

One way to zero in on the problem is to copy the namenode ui link from CM adn then check it from the machine running the namenode to rule out network interference.

 

For example, if the namenode UI link is http://namenode1.example.com:50070/

 

[root@namenode1 ~]# curl http://namenode1.example.com:50070/
<meta HTTP-EQUIV="REFRESH" content="0;url=dfshealth.jsp"/>
<html>
<!--
   Licensed to the Apache Software Foundation (ASF) under one or more
   contributor license agreements.  See the NOTICE file distributed with
   this work for additional information regarding copyright ownership.
   The ASF licenses this file to You under the Apache License, Version 2.0
   (the "License"); you may not use this file except in compliance with
   the License.  You may obtain a copy of the License at

       http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software
   distributed under the License is distributed on an "AS IS" BASIS,
   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
   See the License for the specific language governing permissions and
   limitations under the License.
-->
<head>
<title>Hadoop Administration</title>
</head>

<body>

<h1>Hadoop Administration</h1>

<ul>

<li><a href="dfshealth.jsp">DFS Health/Status</a></li>

</ul>

</body>

</html>
[root@namenode1 ~]# 

 

 

 

Re: http://localhost:50070/ is not working .

Expert Contributor
Actually , I have installed Cloudera Manager in a Single system . There are no other hosts connected to it and I have disabled the Firewall too .
Thanks
Bala

Re: http://localhost:50070/ is not working .

Expert Contributor

is the single system your local workstation? is it a VM?

 

check via curl to rule out your browser.

 

recheck that DNS resolution works for hte hostname CM thinks the node should be.

Re: http://localhost:50070/ is not working .

Expert Contributor
1. This is a Single system .

2. When I run using Curl , I got the below output
[user1@ip00958 ~]$ curl http://ip00958.mycomp.ad:50070/
<!--
Licensed to the Apache Software Foundation (ASF) under one or more
contributor license agreements. See the NOTICE file distributed with
this work for additional information regarding copyright ownership.
The ASF licenses this file to You under the Apache License, Version 2.0
(the "License"); you may not use this file except in compliance with
the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
-->
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="REFRESH" content="1;url=dfshealth.jsp" />
<title>Hadoop Administration</title>
</head>
<body>
&lt;script type="text/javascript">
//<![CDATA[
window.location.href='dfshealth.html';
//]]>
&lt;/script&gt;
<h1>Hadoop Administration</h1>
<ul>
<li><a href="dfshealth.jsp">DFS Health/Status</a></li>
</ul>
</body>
</html>

3. I dont know how to check DNS resolution . Currenly hostname is ip00958.mycomp.ad
Thanks
Bala

Re: http://localhost:50070/ is not working .

Expert Contributor

Curl works, so that's good news. DNS at least works at teh OS level.

 

The current problem appears to be with your web browser then. What browser is it? Do you know if it's running any kind of filtering add on?

Don't have an account?
Coming from Hortonworks? Activate your account here