Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hue is not allowed to impersonate (403)

Solved Go to solution

Re: hue is not allowed to impersonate (403)

Rising Star

@Abiel Flrs The error "User: hue is not allowed to impersonate hue" also signifies that there is no home directory exist for user hue on HDFS.

You can do create (by logging in hdfs user)

su - hdfs -c "hdfs dfs -mkdir /user/hue"

su - hdfs -c "hdfs dfs -chown hue:hadoop /user/hue" [ Or you can make group owner as hdfs ]

su - hdfs -c "hdfs dfs -chmod 755 /user/hue"

means hue user belongs to group hadoop/hdfs

The other error (Only in case of secure Cluster ) ExceptionType:WebHdfsException Security exception may occur

if this is not set for WebHDFS Authorization: auth=KERBEROS;proxyuser=hue

If you are trying access hive by any chance from hue set this param hive.server2.enable.impersonation

View solution in original post

Highlighted

Re: hue is not allowed to impersonate (403)

This helped me access HCatalog, and besswax, thank you.

In addition to your suggestion I also changed the datanode directories permissions from 750 to 755. Not sure if "not recommended".

But until now, I am unable to access the filebrowser...

Don't have an account?
Coming from Hortonworks? Activate your account here