Support Questions
Find answers, ask questions, and share your expertise

mysql-community-server package not found on HDP-UTILS-1.1.0.22 repo

Explorer

The MySQL Server Install fails on HDP 2.6.4 with following error :

resource_management.core.exceptions.ExecutionFailed:
Execution of '/usr/bin/yum -d 0 -e 0 -y install mysql-community-release'
returned 1. Error: Nothing to do

This error is because the mysql-community-server package not found on HDP-UTILS-1.1.0.22 repo. With the HDP-UTILS-1.1.0.21 the installation is successful as the package is existing in that repo.

In the hortonworks HDP installation document the HDP-UTILS version in URL for is shown as HDP-UTILS-1.1.0.21, however during the actual installation the version for HDP-UTILS is HDP-UTILS-1.1.0.22. (https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/hdp_26_repositories.html )

Is there a specific reason for not including mysql-community-server package in HDP-UTILS-1.1.0.22 repo ? Should it be pre-installed?

1 ACCEPTED SOLUTION

Accepted Solutions

@Sonia Garudi,

From HDP 2.6.4, due to licensing issues mysql was removed. All the GPL licensed components will be removed from now. If you are using mysql for hive then you should install it by yourself.

Thanks,

Aditya

View solution in original post

6 REPLIES 6

@Sonia Garudi,

From HDP 2.6.4, due to licensing issues mysql was removed. All the GPL licensed components will be removed from now. If you are using mysql for hive then you should install it by yourself.

Thanks,

Aditya

View solution in original post

Explorer

@Aditya Sirna, thanks for the clarification.

However, according to the https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.4/bk_support-matrices/content/ch_matrices-hdp..., Mysql instance will be installed by Ambari by default for Hive. Is it documented anywhere else that Mysql should be installed as a pre-req for Hive or is this to be updated yet?

Explorer

Also, I noticed that the link for hdp-utils.repo in ppc documentation (https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation-ppc/content/hdp_26_repositories.html) is broken and the HDP-UTILS repo link is present in the hdp.repo.

New Contributor

In a fresh install, HDP will attempt to install MySQL using the command above. I have not found a clean way to create a working repository for MySQL (I either get the above error or a conflict). Has anyone found a way to get this to work within the context of the HDP install or must it always be installed and configured *before* installing HDP?

Explorer

I had the same issue and I am able to resolve it by Download and add the repository, then update.

wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm
sudo rpm -ivh mysql-community-release-el7-5.noarch.rpm
yum update

I assume you have taken care the below.

yum install -y mysql-connector-java
ambari-server setup --jdbc-db=mysql --jdbc-driver=/usr/share/java/mysql-connector-java.jar

New Contributor

Hi Pavan -- that did indeed allow the install to proceed, but something must be wrong somewhere. It can't seem to configure the database for Hive. I get an error on startup about how the database can't be accessed by the node. Sigh....this all worked in 2.6.3......

  1. org.apache.hadoop.hive.metastore.HiveMetaException:Failed to get schema version.
  2. Underlying cause: java.sql.SQLException:null, message from server:"Host 'rh74-full.ibm.com' is not allowed to connect to this MySQL server"
  3. SQL Error code:1130
  4. org.apache.hadoop.hive.metastore.HiveMetaException:Failed to get schema version.