Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Failed

Solved Go to solution

oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Failed

New Contributor

Hello All

I'm getting the following error with any oozie client commands

Authentication exception: GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos credentails)

 It was working well untilk a few days ago when this started.

I have a valid kerberos ticket (klist + hdfs dfs -ls / or anything but oozie work perfectly well).

Also restarted oozie, no better luck

Any ideas, I could not find anything wrong with the configuration so far

Thank you for any suggestion!

Ioan

1 ACCEPTED SOLUTION

Accepted Solutions

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

New Contributor

I was able to resolve the issue by doing the following:

- remove LB name from oozie in CM + restart oozie

- put back the LB name in oozie + restart oozie

Then it worked, it probably needed to regenerate some krb tickets

Ioan

7 REPLIES 7

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Guru
Can you please share the Oozie command that you ran? Also, any errors you can capture from the Oozie server log?

Have you also tried a few different users, like "hdfs", "oozie", "hive" etc to see if behaviours are different due to user difference?

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

New Contributor

Hello

 

Any oozie client command fails, the specific one I used is

oozie jobs -auth KERBEROS  -oozie https://[redacted-server-same]:11443/oozie

 

Any other Hadoop works perfectly (with same keytab) - for example hdfs dfs -ls / works like a charm

Thanks for your help

Ioan

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

New Contributor

I was able to resolve the issue by doing the following:

- remove LB name from oozie in CM + restart oozie

- put back the LB name in oozie + restart oozie

Then it worked, it probably needed to regenerate some krb tickets

Ioan

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Guru
Good finding, looks like the keytab file for Oozie was outdated.
Highlighted

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

New Contributor

Hi 

 

When you say LB name, what is it that you are referring to in the CM config.

 

Thanks,

Vinay Nallan.

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Guru
@Vinay,

I would think it is "Oozie Load Balancer" under CM > Oozie > Configuration.

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

New Contributor

Hi folks -

From talking to support, it seems the issue could be related to HA Proxy.

As a "resolkution", we have disabled HA and everything works great.

Let's face it - we do not really need HA for oozie client - so this was an acceptable enough resolution for us

Thank you for following up though!

Ioan

Don't have an account?
Coming from Hortonworks? Activate your account here