Support Questions

Find answers, ask questions, and share your expertise

oozie cli doesn't work after enabling tls option

Rising Star

Hi Guys,


I have a problem with oozie on my cloudera cluster. I enabled TLS encryption for admin console and Agents. I specified Keystore and Truststore File location and passwords in configuration tab for oozie.


When i try to curl oozie:

oozie admin -oozie https://ukgs2hdm02.cwglobal.local:11443/oozie -status


Error: IO_ERROR : Error while connecting Oozie server. 
No of retries = 1. Exception = PKIX path building failed: unable to find valid certification path to requested target

I was thinking about importing host certificate to a default java keystore but find this:



and I don't know which one should I use?


Here are my files related to cert:

-rw-r-----. 1 root         tls  1996 May 31 13:08 cdh_host.key
-rw-r-----. 1 root         tls  2159 May 31 13:08 cdh_host.keystore
-r--r-----. 1 oozie        tls  2159 Sep 13 09:45 cdh_host.oozie.keystore
-rw-r-----. 1 root         tls  1123 May 31 13:08 cdh_host.pem
-r-xr--r--. 1 cloudera-scm tls  8754 Sep  7 13:39 truststore.jks
-rw-r-----. 1 root         tls 11961 Sep  7 13:39 truststore.pem
-rw-r-----. 1 root         tls   789 May 31 13:08 ukgs2hdm02.cwglobal.local.cer

oozie keystore is the same as the host keystore.


I have added certificate to all default java truststores and still the same problem.


Oozie web console works just fine.


Any ideas?


Rising Star
Solved. I missed one of the java default truststore files..........

View solution in original post


Rising Star
Solved. I missed one of the java default truststore files..........


Hi @andrzej_jedrzej, can you explain how can you solve this problem? 

thank you.

New Contributor

can you explain how did you resolve this issue.

Rising Star
You have to update the default java truststore with your certs, e.g. root CA.
Are you using self-signed certs?


Hi, am using self signed certificates and tried to enable TLS parameters to all the services, so except Oozie. Oozie is showing some health issues, Oozie webserver cannot be communicated.