Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-09-2020 09:19 PM
After making changes as
ssh-copy-id -i /home/oozie/.ssh/id_rsa.pub [email protected]
getting permission issue in oozie workflow
oozi-W@ssh-34f1] Error starting action [ssh-34f1]. ErrorType [NON_TRANSIENT], ErrorCode [AUTH_FAILED], Message [AUTH_FAILED: Not able to perform operation [ssh -o PasswordAuthentication=no -o KbdInteractiveDevices=no -o StrictHostKeyChecking=no -o ConnectTimeout=20 abc.com mkdir -p oozie-oozi/0000000-201209133111712-oozie-oozi-W/ssh-34f1--ssh/ ] | ErrorStream: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password,keyboard-interactive).
Created 12-28-2020 05:13 AM
@syedshakir This is most probably ssh is not setup properly. You can try below steps.
On the Oozie Server host run the command:
ps -ef| grep oozie
Identify the user that runs the Oozie server. For example, the user is oozie
Modify /etc/passwd file to edit the user oozie
oozie:x:485:483:Oozie User:/var/lib/oozie:/bin/false
to:
oozie:x:485:483:Oozie User:/var/lib/oozie:/bin/bash
Note: This will enable the user oozie to login.
In the command prompt switch user as oozie:
su - oozie
Verify that the user is switched by executing the command:
id
Execute ssh-keygen:
Note:Do not give any password. This generates Public and Private Key for passwordless authentication and saves it in the Oozie user's home directory.
ssh-keygen
Execute ssh-copy-id to copy the public key to user’s home directory in the remote host. This user will be the one that runs ssh commands in remote host:
ssh-copy-id -i /home/oozie/.ssh/id_rsa.pub [email protected]
Test by executing ssh without a password to confirm a successful authentication:
ssh [email protected]
Run the Oozie workflow and verify success.
Created 12-28-2020 05:13 AM
@syedshakir This is most probably ssh is not setup properly. You can try below steps.
On the Oozie Server host run the command:
ps -ef| grep oozie
Identify the user that runs the Oozie server. For example, the user is oozie
Modify /etc/passwd file to edit the user oozie
oozie:x:485:483:Oozie User:/var/lib/oozie:/bin/false
to:
oozie:x:485:483:Oozie User:/var/lib/oozie:/bin/bash
Note: This will enable the user oozie to login.
In the command prompt switch user as oozie:
su - oozie
Verify that the user is switched by executing the command:
id
Execute ssh-keygen:
Note:Do not give any password. This generates Public and Private Key for passwordless authentication and saves it in the Oozie user's home directory.
ssh-keygen
Execute ssh-copy-id to copy the public key to user’s home directory in the remote host. This user will be the one that runs ssh commands in remote host:
ssh-copy-id -i /home/oozie/.ssh/id_rsa.pub [email protected]
Test by executing ssh without a password to confirm a successful authentication:
ssh [email protected]
Run the Oozie workflow and verify success.