Support Questions

Find answers, ask questions, and share your expertise not found


Trying to get serde working with zeppelin and/or the spark shell. Running the following in either

val links = sqlContext.sql("SELECT * FROM test_links LIMIT 10")

Produces an error

ERROR hive.log: error in initSerDe: java.lang.ClassNotFoundException Class not found java.lang.ClassNotFoundException: Class not found

Tried added this to /etc/spark/conf/hive-site.xml


<name>hive.aux.jars.path</name> <value>file:///usr/hdp/</value>


But am still getting the error.


New Contributor

This has been solved previously: 1. HIVE_AUX_JARS_PATH in the or set on your shell (not hive cli) will override the one set by "hive.aux.jars.path" in hive-site.xml. However calling "hive -hiveconf hive.aux.jars.path=..." will override HIVE_AUX_JARS_PATH setting in Using "hive --auxpath ..." will append file to any settings you may have in HIVE_AUX_JARS_PATH.2. Since we ship the Apache Hive binaries so hive.reloadable.aux.jars.path should be supported on any hive shipped since HDP "hdfs:///" is supported on add jar, doubt if hive.aux.jars.path supports it.4. Wildcards are not supported in both hive.aux.jars.path and add jar. See previous post by Deepesh (looks like a HWX worker) at


Thanks, adding the jar to HIVE_AUX_JARS_PATH in got SerDe working in zeppelin