Support Questions
Find answers, ask questions, and share your expertise

requirement for ACLs

Master Collaborator

I have a document showing how to set ACLs in hadoop but it has a pre-requisite of setting the following policy. but this policy is missing from my HDP 2.5 ?

set the "dfs.namenode.acls.enabled" to true (HDFS configs).

1 ACCEPTED SOLUTION

Accepted Solutions

Expert Contributor
By default, ACLs are disabled, so you'll have to add the property to HDFS service.
  1. In Ambari, select the HDFS service.
  2. Select the Configs tab.
  3. Find or scroll to "Custom hdfs-site"
  4. Click Add Property.
  5. Enter the value: dfs.namenode.acls.enabled=true
  6. Save your changes and add a comment.

View solution in original post

3 REPLIES 3

Expert Contributor
By default, ACLs are disabled, so you'll have to add the property to HDFS service.
  1. In Ambari, select the HDFS service.
  2. Select the Configs tab.
  3. Find or scroll to "Custom hdfs-site"
  4. Click Add Property.
  5. Enter the value: dfs.namenode.acls.enabled=true
  6. Save your changes and add a comment.

View solution in original post

New Contributor

Do I need to restart the services.I added the below property but no luck.

 

dfs.namenode.acls.enabled=true

 

Read below very good article about HDFS Acls:

https://hortonworks.com/blog/hdfs-acls-fine-grained-permissions-hdfs-files-hadoop/

As mentioned by @bhagan, Acls are turned off by default. You would need to enable them by setting dfs.namenode.acls.enabled=true in hdfs-site