Support Questions
Find answers, ask questions, and share your expertise

sqoop export syntax to export hive table to Sql Server Database table.

Expert Contributor

I want to export hive table to RDBMS database table. I tried below command but it only works when the table is in hive "default" database.

sqoop export --connect "jdbc:sqlserver://x.x.x.x:1433;username=aaa@bbb;password=qqqq;database=dddd" --table table1 --hcatalog-table tbl1 but i want to export table from database i have created in hive.

7 REPLIES 7

Super Guru
@heta desai

I think the database option should be "--hcatagol-database" otherwise the default database is used which is what the behavior you are seeing. Checkt he following document for hcatalog integration with sqoop.

https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.2/bk_dataintegration/content/sqoop-hcatalog-i...

Expert Contributor

it worked for me. thank you so much.

Super Guru

@heta desai

Thanks. If the answer helped, can you please accept it.

New Contributor

sqoop export \

–connect jdbc:oracle:thin:@enkx3-scan:1521:dbName \ –username user \ –password password123 \ –direct \ –export-dir ‘/user/hive/warehouse/test_oracle.db/my_all_objects_sqoop’ \ –table testtable \ –fields-terminated-by ‘\001’

Expert Contributor

thank you.

New Contributor

I solved the issue by converting the Hive table from managed to External

 

CREATE EXTERNAL TABLE new_table
AS
SELECT *
FROM old_table

Community Manager

Hi @Tremo, as this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post.



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.