Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Solved Go to solution
Highlighted

unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Expert Contributor

@Neeraj Sabharwal

unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1 Error : On host role HDFS_CLIENT in invalid state.

Invalid transition. Invalid event: HOST_SVCCOMP_OP_IN_PROGRESS at INSTALL_FAILED
1 ACCEPTED SOLUTION

Accepted Solutions

Re: unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Expert Contributor

I have resolved the issue by performing

/usr/bin/hdp-select --- it displays all the installed components along with the versions., which showed the error about which client component is having issue... it is due to the symlink issue for the client component accumulo-client - None accumulo-gc - None accumulo-master - None accumulo-monitor - None accumulo-tablet - None accumulo-tracer - None atlas-server - 2.4.0.0-169 falcon-client - 2.4.0.0-169 falcon-server - 2.4.0.0-169 flume-server - None hadoop-client - 2.4.0.0-169 hadoop-hdfs-datanode - 2.4.0.0-169 hadoop-hdfs-journalnode - 2.4.0.0-169 hadoop-hdfs-namenode - 2.4.0.0-169 hadoop-hdfs-nfs3 - 2.4.0.0-169 hadoop-hdfs-portmap - 2.4.0.0-169 hadoop-hdfs-secondarynamenode - 2.4.0.0-169 hadoop-httpfs - 2.4.0.0-169 hadoop-mapreduce-historyserver - 2.4.0.0-169 hadoop-yarn-nodemanager - 2.4.0.0-169 hadoop-yarn-resourcemanager - 2.4.0.0-169 hadoop-yarn-timelineserver - 2.4.0.0-169 hbase-client - 2.4.0.0-169 hbase-master - 2.4.0.0-169 hbase-regionserver - 2.4.0.0-169 hive-metastore - 2.4.0.0-169 hive-server2 - 2.4.0.0-169 hive-webhcat - 2.4.0.0-169 kafka-broker - 2.4.0.0-169 knox-server - None mahout-client - None oozie-client - 2.4.0.0-169 oozie-server - 2.4.0.0-169 phoenix-client - 2.4.0.0-169 phoenix-server - 2.4.0.0-169 ranger-admin - None ranger-kms - None ranger-usersync - None slider-client - None spark-client - 2.4.0.0-169 spark-historyserver - 2.4.0.0-169 spark-thriftserver - 2.4.0.0-169 sqoop-client - 2.4.0.0-169 sqoop-server - 2.4.0.0-169 storm-client - None storm-nimbus - None storm-slider-client - None storm-supervisor - None zeppelin-server - None zookeeper-client - 2.4.0.0-169 zookeeper-server - 2.4.0.0-169

View solution in original post

4 REPLIES 4
Highlighted

Re: unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Mentor

Please contact support and paste Ambari logs

Highlighted

Re: unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

@Krishna Srinivas

Restart ambari server and make sure that you can use ambari to start and stop services before installing or removing anything.

Whats the output of the following?

select * from host_version;

Re: unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Expert Contributor

I have resolved the issue by performing

/usr/bin/hdp-select --- it displays all the installed components along with the versions., which showed the error about which client component is having issue... it is due to the symlink issue for the client component accumulo-client - None accumulo-gc - None accumulo-master - None accumulo-monitor - None accumulo-tablet - None accumulo-tracer - None atlas-server - 2.4.0.0-169 falcon-client - 2.4.0.0-169 falcon-server - 2.4.0.0-169 flume-server - None hadoop-client - 2.4.0.0-169 hadoop-hdfs-datanode - 2.4.0.0-169 hadoop-hdfs-journalnode - 2.4.0.0-169 hadoop-hdfs-namenode - 2.4.0.0-169 hadoop-hdfs-nfs3 - 2.4.0.0-169 hadoop-hdfs-portmap - 2.4.0.0-169 hadoop-hdfs-secondarynamenode - 2.4.0.0-169 hadoop-httpfs - 2.4.0.0-169 hadoop-mapreduce-historyserver - 2.4.0.0-169 hadoop-yarn-nodemanager - 2.4.0.0-169 hadoop-yarn-resourcemanager - 2.4.0.0-169 hadoop-yarn-timelineserver - 2.4.0.0-169 hbase-client - 2.4.0.0-169 hbase-master - 2.4.0.0-169 hbase-regionserver - 2.4.0.0-169 hive-metastore - 2.4.0.0-169 hive-server2 - 2.4.0.0-169 hive-webhcat - 2.4.0.0-169 kafka-broker - 2.4.0.0-169 knox-server - None mahout-client - None oozie-client - 2.4.0.0-169 oozie-server - 2.4.0.0-169 phoenix-client - 2.4.0.0-169 phoenix-server - 2.4.0.0-169 ranger-admin - None ranger-kms - None ranger-usersync - None slider-client - None spark-client - 2.4.0.0-169 spark-historyserver - 2.4.0.0-169 spark-thriftserver - 2.4.0.0-169 sqoop-client - 2.4.0.0-169 sqoop-server - 2.4.0.0-169 storm-client - None storm-nimbus - None storm-slider-client - None storm-supervisor - None zeppelin-server - None zookeeper-client - 2.4.0.0-169 zookeeper-server - 2.4.0.0-169

View solution in original post

Highlighted

Re: unable to install the client components after ambari upgrade from 2.1.2 to 2.2.1

Super Collaborator

My problem is that ambari detect that the client installed is failed but the client is working correctly.

I have all client failled after upgrade ambari 2.2.1, what can i do??

[root@lnxbig05 /]# /usr/bin/hdp-select
accumulo-client - None
accumulo-gc - None
accumulo-master - None
accumulo-monitor - None
accumulo-tablet - None
accumulo-tracer - None
atlas-server - 2.3.2.0-2950
falcon-client - 2.3.2.0-2950
falcon-server - 2.3.2.0-2950
flume-server - 2.3.2.0-2950
hadoop-client - 2.3.2.0-2950
hadoop-hdfs-datanode - 2.3.2.0-2950
hadoop-hdfs-journalnode - 2.3.2.0-2950
hadoop-hdfs-namenode - 2.3.2.0-2950
hadoop-hdfs-nfs3 - 2.3.2.0-2950
hadoop-hdfs-portmap - 2.3.2.0-2950
hadoop-hdfs-secondarynamenode - 2.3.2.0-2950
hadoop-httpfs - 2.3.2.0-2950
hadoop-mapreduce-historyserver - 2.3.2.0-2950
hadoop-yarn-nodemanager - 2.3.2.0-2950
hadoop-yarn-resourcemanager - 2.3.2.0-2950
hadoop-yarn-timelineserver - 2.3.2.0-2950
hbase-client - 2.3.2.0-2950
hbase-master - 2.3.2.0-2950
hbase-regionserver - 2.3.2.0-2950
hive-metastore - 2.3.2.0-2950
hive-server2 - 2.3.2.0-2950
hive-webhcat - 2.3.2.0-2950
kafka-broker - 2.3.2.0-2950
knox-server - None
mahout-client - None
oozie-client - 2.3.2.0-2950
oozie-server - 2.3.2.0-2950
phoenix-client - 2.3.2.0-2950
phoenix-server - 2.3.2.0-2950
ranger-admin - None
ranger-kms - None
ranger-usersync - None
slider-client - 2.3.2.0-2950
spark-client - 2.3.2.0-2950
spark-historyserver - 2.3.2.0-2950
spark-thriftserver - 2.3.2.0-2950
sqoop-client - 2.3.2.0-2950
sqoop-server - 2.3.2.0-2950
storm-client - 2.3.2.0-2950
storm-nimbus - 2.3.2.0-2950
storm-slider-client - 2.3.2.0-2950
storm-supervisor - 2.3.2.0-2950
zeppelin-server - None
zookeeper-client - 2.3.2.0-2950
zookeeper-server - 2.3.2.0-2950

Many thanks

Don't have an account?
Coming from Hortonworks? Activate your account here