Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

unable to start service from hdp sandbox 2.6.5

avatar
Contributor

While trying to install HDP 2.6.5 sandbox on windows 10 with wmare, after starting the vm with 4cpu and 10g ram, i can login the ambari but all service can't be started

109256-hdp-sandbox-error1.png

I have tried "restart all" service or restart zookeeper via the account: raj_ops, but no luck.

109265-hdp-sandbox-error2.png

 

1 ACCEPTED SOLUTION

avatar
Master Mentor

@forest lin

It looks like your ambari agent might not be running.

1. Please try this:

# ambari-agent restart


2. Can you please check and share the ambari agent log ?

"/var/log/ambari-agent/ambari-agent.log"

3. Please check what all processes are already running on that Sandbox? It might be possible that few components might already be running but agent might not be able to show the proper status to Amabri Server due to some broker communication / OR agent down issue.


4. Please check the free memory available on the sandbox host:

# free -m

5. Also after restarting the ambari server do you see any error in the ambari-server.log?


.


View solution in original post

5 REPLIES 5

avatar
Contributor

i also tried to use "ambari-admin-password-reset" to set admin password then login ambari with admin, then repeat the start service actions, but no luck to start hdp services..

avatar
Master Mentor

@forest lin

It looks like your ambari agent might not be running.

1. Please try this:

# ambari-agent restart


2. Can you please check and share the ambari agent log ?

"/var/log/ambari-agent/ambari-agent.log"

3. Please check what all processes are already running on that Sandbox? It might be possible that few components might already be running but agent might not be able to show the proper status to Amabri Server due to some broker communication / OR agent down issue.


4. Please check the free memory available on the sandbox host:

# free -m

5. Also after restarting the ambari server do you see any error in the ambari-server.log?


.


avatar
New Member

How can I start the agent? I would need to SSH into the sandbox correct?

When I try to SSH using root, I get asked for a password, what should the password be?

avatar
Visitor

the password would be 'hadoop'

avatar
Contributor

after restart the ambari-agent service, i can start the zk , hdfs, mr, hive , spark2 now.

thanks @Jay Kumar SenSharma