Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

what is the username and password for beeline

avatar

I am using cloudera VB. I am trying to login to beeline. I tried the username and passwod (empty) but it's not working :-

!connect jdbc:hive2://localhost:10000/
Connecting to jdbc:hive2://localhost:10000/
Enter username for jdbc:hive2://localhost:10000/:
Enter password for jdbc:hive2://localhost:10000/:
Error: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:10000/: java.net.ConnectException: Connection refused (state=08S01,code=0)
0: jdbc:hive2://localhost:10000/ (closed)>

@ 

 

[cloudera@quickstart ~]$ beeline
2019-10-09 17:06:46,217 WARN [main] mapreduce.TableMapReduceUtil: The hbase-prefix-tree module jar containing PrefixTreeCodec is not present. Continuing without it.
Beeline version 1.1.0-cdh5.7.0 by Apache Hive
beeline> !connect jdbc:hive2://localhost:10000/
scan complete in 5ms
Connecting to jdbc:hive2://localhost:10000/
Enter username for jdbc:hive2://localhost:10000/: hadoop
Enter password for jdbc:hive2://localhost:10000/:
Error: Could not open client transport with JDBC Uri: jdbc:hive2://localhost:10000/: java.net.ConnectException: Connection refused (state=08S01,code=0)
0: jdbc:hive2://localhost:10000/ (closed)>

 

Can someone know the username and password to login to beeline. I have checked hive metastore and hive server2. it's working :-

[cloudera@quickstart ~]$ sudo service hive-metastore status
Hive Metastore is running

[cloudera@quickstart ~]$ sudo service hive-server2 status
Hive Server2 is running [ OK ]

1 ACCEPTED SOLUTION

avatar

I have solved the issue. My Namenode was in safe mode. So i have turned off safe mode by using :- hadoop dfsadmin -safemode leave

View solution in original post

1 REPLY 1

avatar

I have solved the issue. My Namenode was in safe mode. So i have turned off safe mode by using :- hadoop dfsadmin -safemode leave