Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

[zeppelin] Error trying to load dependecies and execute basic interpreter code

avatar
Contributor

Hello,

I am working on a cluster with an installation of HDP-2.5.

I am trying to load dependency in zeppelin using the traditional way (I tried to register the repo in zeppelin and to add the dependency in the spark interpreter but it is not working better than this method so...) and to execute some code at the interpreter level.

The execution of the div in order to include the dependency and the execution of the code is systematically failing.

I am left with a non working zeppelin.

Note: I reinstalled it but it did not change anything.

Note2: zeppelin logs are available in attachment.

1 ACCEPTED SOLUTION

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
4 REPLIES 4

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

It works ! Thanks.

Do you have any idea about the cause however ?

avatar
Contributor

Could be due to some issue in the dep. When you say traditional way, did you mean %dep interpreter? or you did "Load Dependencies to Interpreter" method mentioned in https://zeppelin.apache.org/docs/0.6.2/manual/dependencymanagement.html

avatar
Contributor

I tried both methods and just the first one with %spark.dep or %dep is working. Not the latter you signaled, however much more interesting for me of course.

For the latter method I declared a repository with ID: "hortonwork" and URL: "http://repo.hortonworks.com/content/groups/public/"

I edited the spark interpreter and added this line to dependency:

com.hortonworks:shc-core:1.0.1-1.6-s_2.10 (I checked manually that the jar is indeed here.)