Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

[ANNOUNCE] Cloudera Enterprise 5.7.2 Released

avatar
Master Collaborator

Dear CDH, Cloudera Manager, and Cloudera Navigator users,

 

We are pleased to announce the release of Cloudera Enterprise 5.7.2 (CDH 5.7.2, Cloudera Manager 5.7.2, and Cloudera Navigator 2.6.2).  

This release fixes key bugs and includes the following:

  • CDH fixes for the following issues:

    • HADOOP-11409 - FileContext.getFileContext can stack overflow if default fs misconfigured

    • HADOOP-12787 - KMS SPNEGO sequence does not work with WebHDFS

    • HADOOP-13251 - Authenticate with Kerberos credentials when renewing KMS delegation token

    • HDFS-10360 - DataNode may format directory and lose blocks if current/VERSION is missing

    • HBASE-11625 - Reading data block throws "Invalid HFile block magic" and can not switch to hdfs checksum

    • HIVE-9499 - hive.limit.query.max.table.partition makes queries fail on non-partitioned tables

    • HIVE-10685 - Alter table concatenate operator will cause duplicate data

    • IMPALA-1928 - Fix Thrift client transport wrapping order

    • HUE-4113 - [Pig] Hue breaks when user has only access to pig app

    • SQOOP-2846 - Sqoop Export with update-key failing for avro data file

 

For a full list of upstream JIRAs fixed in CDH 5.7.2, see the issues fixed section of the Release Notes.

  • Cloudera Manager fixes for the following issues
    • Unable to start Hue on cluster that's using Kerberos and Isilon, Hue service can now start with Isilon if Kerberos is enabledXSS in Kerberos activation: In lower releases, there was an XSS vulnerability on the Kerberos page. This is now fixed
    • XSS in host addition: In lower releases, there was an XSS vulnerability on the Add Hosts page. This is now fixed.
    • Cloudera Manager Agent clears out JN data directories that leads to HDFS not restarting
    • Files excluded from replication are not replicated if they are renamed: If a file excluded from replication by an exclusion filter is renamed, it is now replicated properly

For a full list of issues fixed in Cloudera Manager 5.7.2, see the issues fixed section of the Release Notes.

  • Cloudera Navigator fixes for the following issues:

    • java.lang.IllegalArgumentException error causes Navigator to crash

    • Navigator Metadata Server fails with nav.batch and a high amount of heap


For a full list of issues fixed in Cloudera Navigator 2.6.2, see the issues fixed section of the Release Notes.

We look forward to you trying it, using the information below:

As always, we are happy to hear your feedback. Please send your comments and suggestions to the user group or through our community forums. You can also file bugs through our external JIRA projects on issues.cloudera.org.