Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

What's New @ Cloudera

Find the latest Cloudera product news
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Data Engineering HA template for Data Hub on AWS delivers end-to-end resiliency

avatar
Cloudera Employee

The Data Engineering HA template has graduated from Preview status to GA on AWS today, with the release of Cloudera Runtime 7.2.9. It now supports fault-tolerant access to all cluster web UIs and end-to-end reliability for more workload types. 

 

The addition of a load balanced, highly available Apache Knox gateway service configured for transparent failover provides this additional resiliency for end users accessing web interfaces of the cluster and for scheduled or ad hoc workloads.  Specifically, Hive workloads submitted to HiveServer2 via the Knox gateway and workloads that access WebHDFS through Knox can seamlessly tolerate instance failures of master nodes running the Knox gateway.  This capability is thanks to the recent addition of an external load balancer to the cluster, and adds to the highly available HDFS, YARN and HiveServer 2 services offered in earlier versions.

 

Future releases of Data Engineering  HA will support highly available Oozie and Cloudera Manager services, ensuring that nearly all workload types can seamlessly tolerate failures of any once instance in the cluster.

 

To learn more, visit the documentation about Data Engineering HA.