Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 10-21-2014 05:45 AM - edited 09-16-2022 02:10 AM
Hi,
we updated sqoop from cdh5.0.1 to cdh5.2 and now it fails everytime with a GC overhead limit exceeded error.
The old version was able to import over 14GB of data over one mapper and the import fails now when a mapper gets too many rows. I checked a heap dump and the memory was completely used by over 3.5 million rows of data (-Xmx 1700M).
The connector is mysql-jdbc version 5.1.33 and the job imports the data as text file in a have table.
Can I avoid this with a setting or is this a bug that should go to jira?
Thank you,
Jürgen