Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 11-12-2014 10:18 PM - edited 09-16-2022 02:12 AM
Hi,
We have CDH 5.1 running on production for a few month already with no issues.
Recently we've created another cluster for qa environment and installed CDH 5.2 through Cloudera Manager.
And when we tried to some Oozie workflows (the same jobs as on production) we got following error:
Error: java.io.IOException: Type mismatch in key from map: expected org.apache.hadoop.io.LongWritable, received org.apache.hadoop.io.Text
I've figured this error occured because hadoop tried to use IdentityMapper class instead of our streaming processors.
I've tried a lot of different options but nothing helped so far.
The closest I could get is to compare actual jobConf files that we get on production (CDH 5.1) and on new cluster (CDH 5.2). And I figured that on new cluster jobConf doesn't contain following properties:
stream.map.streamprocessor
stream.reduce.streamprocessor
which if I understand correctly are used by hadoop-streaming.jar
Have no idea where to look next.
I would really appreciate any help with this issue.
Thanks,
Anatoly