Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Who agreed with this topic

Cannot build from Ambari source due to S3 links missing

New Contributor

Due to Ambari binaries and repos behind a paywall now, I am trying to build Ambari from source using 2.7.5 using this archive:

Ambari Metrics Collector was failing due to this error.


[ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (default) on project ambari-metrics-timelineservice: An Ant BuildException has occured: Can't get to /tmp/apache-ambari-2.7.5-src/ambari-metrics/ambari-metrics-timelineservice/target/embedded/hbase.tar.gz
[ERROR] around Ant part ...<get usetimestamp="true" src="" dest="/tmp/apache-ambari-2.7.5-src/ambari-metrics/ambari-metrics-timelineservice/target/embedded/hbase.tar.gz"/>... @ 5:272 in /tmp/apache-ambari-2.7.5-src/ambari-metrics/ambari-metrics-timelineservice/target/antrun/build-Download HBase.xml

My understanding is the S3 resources were removed so i tried to replace the references to hbase, hadoop, and phoenix using what available versions i could find from a mirror of

and I was able to get further into the build.

However, i can't get past issues with Phoenix.  I've tried different versions of 5.0.0 and 5.1.0 that are publicly available and keep running into different issues. Mainly with versions of 5.0.x, having to rename folders and versions in the pom.xml files, getting pom issues because it can't match a version from, and with 5.1.0, unit test errors.

Has anyone tried to build from source and been successful since the paywall went up? 
Any alternative locations to what was being hosted from
Any mirrors to the binaries for 2.7.4 and 2.7.5 that were previously available from

Paying for a subscription is not a solution for me.  Ambari is open source but now even that option seems to be broken thanks to a strong reliance to the links that Cloudera has removed.

Who agreed with this topic