Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-04-2016 10:57 PM - edited 09-16-2022 02:55 AM
I am following the steps in Execrice 1 . sqoop is failing. Below is more details.
$ sqoop import-all-tables -m 1 --connect jdbc:mysql://{{cluster_data.manager_node_hostname}}:3306/retail_db --username=retail_dba --password=cloudera --compression-codec=snappy --as-parquetfile --warehouse-dir=/user/hive/warehouse --hive-import
Warning: /opt/cloudera/parcels/CDH-5.4.2-1.cdh5.4.2.p0.2/bin/../lib/sqoop/../accumulo does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
16/01/05 01:45:42 INFO sqoop.Sqoop: Running Sqoop version: 1.4.5-cdh5.4.2
16/01/05 01:45:42 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.
16/01/05 01:45:42 INFO tool.BaseSqoopTool: Using Hive-specific delimiters for output. You can override
16/01/05 01:45:42 INFO tool.BaseSqoopTool: delimiters with --fields-terminated-by, etc.
16/01/05 01:45:42 WARN tool.BaseSqoopTool: It seems that you're doing hive import directly into default
16/01/05 01:45:42 WARN tool.BaseSqoopTool: hive warehouse directory which is not supported. Sqoop is
16/01/05 01:45:42 WARN tool.BaseSqoopTool: firstly importing data into separate directory and then
16/01/05 01:45:42 WARN tool.BaseSqoopTool: inserting data into hive. Please consider removing
16/01/05 01:45:42 WARN tool.BaseSqoopTool: --target-dir or --warehouse-dir into /user/hive/warehouse in
16/01/05 01:45:42 WARN tool.BaseSqoopTool: case that you will detect any issues.
16/01/05 01:45:42 INFO manager.MySQLManager: Preparing to use a MySQL streaming resultset.
16/01/05 01:45:43 ERROR manager.CatalogQueryManager: Failed to list tables
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
....
....
....
Caused by: java.net.UnknownHostException: {{cluster_data.manager_node_hostname}}
at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)
at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:901)
at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1293)
at java.net.InetAddress.getAllByName0(InetAddress.java:1246)
at java.net.InetAddress.getAllByName(InetAddress.java:1162)
at java.net.InetAddress.getAllByName(InetAddress.java:1098)
at com.mysql.jdbc.StandardSocketFactory.connect(StandardSocketFactory.java:190)
at com.mysql.jdbc.MysqlIO.<init>(MysqlIO.java:297)
... 24 more
I am using -m 1 based on earlier thread. MySQL instance is running.
Any assistance will be much appreciated.