Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-04-2016 04:13 PM
The underlying cause of the failure seems to be a failure to start Kafla:
[2016-02-01 19:10:58] ERROR [pipeline-thread-35] - c.c.l.b.UnboundedWaitForApiCommand: Command Start with ID 72 failed. Details: ApiCommand{id=72, name=Start, startTime=Mon Feb 01 19:10:10 EST 2016, endTime=Mon Feb 01 19:10:10 EST 2016, active=false, success=false, resultMessage=Failed to start service., serviceRef=ApiServiceRef{peerName=null, clusterName=Atlas-Test, serviceName=CD-KAFKA-MnViYSKk}, roleRef=null, hostRef=null, parent=null}
Cloudera Manager command execution history should have more details.
I believe get this error because the Kafka parcel is not distributed (as you know Kafka is not included in the CDH parcel). Please add "KAFKA: 0.8.2" to the products {} block. You may also need to add reference to the precise parcel repositories you want to use.