New Contributor
Posts: 3
Registered: ‎05-13-2016
Re: Oozie - Spark Action - Hive

I found a solution, even though it is not the prettiest.

 

In the Spark job, before creating the SparkContext, you need to set a system property for the Hive metastore URI like so:

 

System.setProperty("hive.metastore.uris", "thrift://<your metastore host>:9083");

I have tried setting this through the Oozie configuration but to no avail. So far, this was the only way to make it work. 

View solution in original post

Who Me Too'd this solution