Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-24-2016 04:01 AM - edited 09-16-2022 03:41 AM
Suddenly happend this error.
Since then, never start Service Monitor and Host Monitor.
There are some erros here.
2016-09-24 18:54:31,147 INFO com.cloudera.cmon.firehose.Main: Hosts: 12 2016-09-24 18:54:31,147 INFO com.cloudera.cmon.firehose.Main: Cluster size: MEDIUM 2016-09-24 18:54:31,211 INFO com.cloudera.cmon.tstore.leveldb.LDBResourceManager: Max file descriptors: 32768 2016-09-24 18:54:31,212 INFO com.cloudera.cmon.tstore.leveldb.LDBResourceManager: Setting maximum open fds to: 2048 2016-09-24 18:54:31,311 ERROR com.cloudera.cmon.firehose.Main: Error creating LevelDB timeseries store in directory /var/lib/cloudera-host-monitor/ts org.fusesource.leveldbjni.internal.NativeDB$DBException: Corruption: CURRENT file does not end with newline at org.fusesource.leveldbjni.internal.NativeDB.checkStatus(NativeDB.java:194) at org.fusesource.leveldbjni.internal.NativeDB.open(NativeDB.java:212) at org.fusesource.leveldbjni.JniDBFactory.open(JniDBFactory.java:168) at com.cloudera.cmon.tstore.leveldb.LDBUtils.openVersionedDB(LDBUtils.java:246) at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.openMetadataDB(LDBTimeSeriesMetadataStore.java:149) at com.cloudera.cmon.tstore.leveldb.LDBTimeSeriesMetadataStore.<init>(LDBTimeSeriesMetadataStore.java:139) at com.cloudera.cmon.firehose.Main.main(Main.java:450)
my hadoop Spec is this.
what needs to be done in order to solve it ?
Thanks.