Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Who agreed with this topic

Running pyspark (w/ anaconda ) in oozie via Hue



I'm trying to run a simple python script on Oozie using Hue. I'm using anaconda parcels installed so I've also add in Cloudera manager, spark configuration (Spark Service Advanced Configuration Snippet (Safety Valve) for spark-conf/

if [ -z "${PYSPARK_PYTHON}" ]; then
export PYSPARK_PYTHON=/opt/cloudera/parcels/Anaconda/bin/python

When running the job, i've a python error

ImportError: No module named

, meaning that the PYSPARK_PYTHON doesn't seems to take the one from anaconda.


I've tried to add an arguments with PYSPARK_PYTHON=/opt/cloudera/parcels/Anaconda/bin/python on the spark action via hue, but doesn't seems to work.


If I run the scripts via CLI and spark-submit it works.

If I run other python scripts on Oozie via Hue (without packages from anaconda) it works.


What am I missing ? 😕



Who agreed with this topic