Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Who agreed with this topic

Impala Catalog Server supervisor permissions

avatar
Contributor

I have a problem on a CDH 5.8.0 parcels testsystem starting the Impala Catalog Server. 

The error message is the following: 

 

Can't open /var/run/cloudera-scm-agent/process/148-impala-CATALOGSERVER/supervisor.conf: Permission denied.

The permissions for this file are: 

 

-rw------- 1 root   root    2970 Jun 27 23:01 supervisor.conf

All other files and directories in the /var/run/cloudera-scm-agent/process/148-impala-CATLOGSERVER folder having owner impala and group  impala. 

When I change the permissions it will be overwritten on the next start. 

What is wrong here? 

And what needs to be changed. I recently installed a different service and changed the visudo file, but I have not changed the Impala configuration.

 

Thanks for the advice.

Who agreed with this topic