Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Who agreed with this topic

HDFS tests (canary, connection) fail after enabling security

avatar
Guru

Hi,

after enabling Kerberos security and restarting the cluster, the status of service HDFS shows "Bad", despite the service instances are all "Good".

Seems like just the service checks are failing, error messages from CM:

1.) No connection to determine the active NameNode could be made for the last 3 minute(s)...

2.) Canary test failed to create parent directory for /tmp/.cloudera_health_monitoring_canary_files.

 

and even the Namenode UI cannot be opened successfully => after clicking "Namenode WebUI" (which results in http://hadoop-pg:50070) in service view I receive

"

HTTP ERROR 401

Problem accessing /index.html. Reason:

"

 

How to solve the described issues

a) eliminate failures of hdfs service checks, and

b) being unable to open Namenode-UI 

??

 

thanks in advance, Gerd

 

 

Who agreed with this topic