Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-30-2016 07:48 AM
I have a cluster that has been running pretty smoothly for over a month now that is rather large. I had just fixed an issue with a few DataNodes and was left with the web interface saying that 5 hosts were in maintenance mode when they were not. I tried turning mm on/off but it didn't help so I finally tried a sudo ambari-server restart
Afterwards, I tried to login again and the web interface wouldn't load. Waited a few minutes, still nada.
Looking at today's entries in /var/log/ambari-server/ambari-server.log had errors regarding the metric server but nothing that seemed relevant. The network settings are all the same and haven't changed, I am not sure what went wrong? Any ideas of what logs I should read or what I should try?
EDIT:
Thanks for the fast replies!!
I have attached the info requested as files so this post doesn't extend down a mile.
It looks like the ambari service is not listening on port 8080.
EDIT2:
I ended up rolling back the ambari server vm to an earlier checkpoint and luckily there weren't too many errors to deal with. I will update again if the issue comes back.
Created 01-30-2016 08:37 AM
Could you also restart the ambari agents of your cluster. It'd be good to have some of the errors that you saw in the ambari-server log, could you post some of the log or upload the log file?
After you restarted the ambari server, did it show up in the process (ps -aux | grep ambari-server), also make sure you see the ambari process listening on port 8080 (netstat -anop)
Created 01-30-2016 08:07 PM
I had tried that initially, but no luck
Created 01-30-2016 08:57 PM
@Kyle Pifer Please attach /etc/ambari-server/conf/ambari.properties
Created 01-30-2016 09:01 PM
Created 01-30-2016 09:09 PM
@Kyle Pifer Thanks for sharing the ambari.properties. See this article
You are using default port for sure otherwise you should have client.api.port defined.
Steps:
ambari-server stop
mv/var/log/ambari-server/ambari-server.log /var/log/ambari-server/ambari-server.log.bakup
ambari-server start
now, check whats in the log file.
Created 01-30-2016 09:50 PM
Created 01-30-2016 09:53 PM
@Kyle Pifer This is very strange. No there is no problem on using problem 8080.
Whats in the log when hit the browser? netstat -anp | grep 8080
Created 01-30-2016 09:54 PM
Thats the problem, netstat shows nothing for p 8080.
Created 01-30-2016 09:58 PM
@Kyle Pifer I just did the same exercise in my cluster and I see this http://pastebin.com/008iBDuw
Wait for sometime and see whats coming in ...
restart agents , ambari and run tail -f /var/log/ambari-server/ambari-server.log
Created 01-30-2016 10:02 PM
@Kyle Pifer Whats the output of ambari-server start ?
Created 01-31-2016 01:45 AM
Still nothing in ambari-server log, but the agent logs are showing connection refused to ambariserver:8440