Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 05-25-2016 02:05 AM - edited 09-16-2022 03:21 AM
Starting NODEMANAGER is failing with the below ERROR. 3 Node cluster with running with CDH5.7
org.apache.hadoop.yarn.server.nodemanager.NodeManager registered UNIX signal handlers for [TERM, HUP, INT] org.apache.hadoop.service.AbstractService Service NodeManager failed in state INITED; cause: EPERM: Operation not permitted EPERM: Operation not permitted at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmodImpl(Native Method) at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod(NativeIO.java:230) at org.apache.hadoop.fs.RawLocalFileSystem.setPermission(RawLocalFileSystem.java:660) at org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(RawLocalFileSystem.java:452) at org.apache.hadoop.fs.FilterFileSystem.mkdirs(FilterFileSystem.java:309) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartRecoveryStore(NodeManager.java:152) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:195) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:521) org.apache.hadoop.service.AbstractService When stopping the service NodeManager : java.lang.NullPointerException java.lang.NullPointerException at org.apache.hadoop.yarn.server.nodemanager.NodeManager.stopRecoveryStore(NodeManager.java:162) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceStop(NodeManager.java:275) at org.apache.hadoop.service.AbstractService.stop(AbstractService.java:221) at org.apache.hadoop.service.ServiceOperations.stop(ServiceOperations.java:52) at org.apache.hadoop.service.ServiceOperations.stopQuietly(ServiceOperations.java:80) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:171) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:521) org.apache.hadoop.yarn.server.nodemanager.NodeManager Error starting NodeManager org.apache.hadoop.service.ServiceStateException: EPERM: Operation not permitted at org.apache.hadoop.service.ServiceStateException.convert(ServiceStateException.java:59) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:172) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:521) Caused by: EPERM: Operation not permitted at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmodImpl(Native Method) at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod(NativeIO.java:230) at org.apache.hadoop.fs.RawLocalFileSystem.setPermission(RawLocalFileSystem.java:660) at org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(RawLocalFileSystem.java:452) at org.apache.hadoop.fs.FilterFileSystem.mkdirs(FilterFileSystem.java:309) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartRecoveryStore(NodeManager.java:152) at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:195) at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163) ... 2 more
Created 05-31-2016 10:57 PM
solved by changing the logdir and libdir to another mount.
Created 05-31-2016 01:50 PM
Does this post help? http://gkesavan.blogspot.com/2014/04/yarn-nodemanager-doesnt-start-caused-by.html
Created 05-31-2016 10:57 PM
solved by changing the logdir and libdir to another mount.