Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 07-21-2017 05:58 AM
I am hitting below error when i try to import the deployment.json. Is anything i missed. And how to overcome?
CM Version : 5.12
#curl --upload-file deploymnet.json -u admin:admin 'http://scmhost:7180/api/v17/cm/deployment?deleteCurrentDeployment=true'
{
"message" : "Double-check the URL. Consider adding '\"Content-Type: application/json\"' to your HTTP headers if the URL expects JSON input."
Created 07-21-2017 11:26 PM
Created 07-25-2017 03:20 AM
There is some issues with deployment.json file. I removed the replication content from .jso file and then import suceed
Created 07-21-2017 11:26 PM
Created 07-24-2017 02:44 AM
I added the -H in curl now it gving diferent error.
#curl -H "Content-Type: application/json" --upload-file deploymnet.json -u admin:admin 'http://scmhost:7180/api/v17/cm/deployment?deleteCurrentDeployment=true'
{
"message" : "Impala metadata replication is supported from CDH versions 5.2.0 to (less than) version 5.12.0"
}
Created 07-25-2017 03:20 AM
There is some issues with deployment.json file. I removed the replication content from .jso file and then import suceed