Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-09-2018 08:48 PM
I Followed these steps :
First i took a server(Cent OS 6) from Google Cloud in Asia South reagion. and Executed these commands :
Done! Cloudera manager installed Successfully.
But when I am trying to access http://my_public_ip:7180/ then getting timed out error.
Also i waited for almost an hour after installing cloudera(for startup settings). but again same response.
Created on 01-10-2018 07:37 PM - edited 01-10-2018 07:38 PM
Hello Gaurav,
Please share the output of curl on http://my_public_ip:7180 from cm host itself.
And tcpdump from the source host.
Created 01-09-2018 09:47 PM
The first thing to check is whether the server is up and listening.
- service cloudera-scm-server status
- netstat -nap |grep 7180
Next, check the Cloudera Manager server log to find out if it had trouble starting.
- review /var/log/cloudera-scm-server/cloudera-scm-server.log
If you do find that Cloudera Manager is listening on 7180, make sure it is listening on all interfaces.
If you are getting a timed out message or a hang, that makes me suspicious that the server is coming up, but your route to that host is not working properly. Could there be a proxy configured in your browser that cannot connect to your CM server?
You might try tcpdump or browser developer tools to find out what the client/server communication looks like.
I'd start with making sure the server is listening on 7180 and review the log for any exceptions or errors that look important.
Created 01-10-2018 07:03 AM
Hi @bgooley,
Thankyou for response.
here what i got
1. service cloudera-scm-server status
Running
2. netstat -nap |grep 7180
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN 1623/java
and it seems that all right in log file.
Created on 01-10-2018 07:37 PM - edited 01-10-2018 07:38 PM
Hello Gaurav,
Please share the output of curl on http://my_public_ip:7180 from cm host itself.
And tcpdump from the source host.
Created 01-14-2018 07:53 PM
Created 03-27-2018 01:14 PM
I am also facing the same issue, can you let me know how did you solve it
Created 03-27-2018 04:19 PM
Hi @dewdrop,
Please see my initial comments in this thread. We'll need to know more about what you try to do and what the result is.
Thanks,
Ben
Created 03-28-2018 11:32 AM
Hi,
I've installed cloudera Manager on Amazon VM Ec2 server.
disabled SELinux, disabled filewall setting
sudo service cloudera-scm-server status - up and running
netstat -nap |grep 7180
(No info could be read for "-p": geteuid()=1000 but you should be root.)
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN
i tried these two on the running server
ec2-user@ip-172-31-44-224 ~]$ curl -i http://localhost:7180
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=sgoy1bydivup1kmcoqv110bfu;Path=/;HttpOnly
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 07 Feb 2018 17:44:18 GMT
Content-Length: 63
Accept-Ranges: bytes
Cache-Control: max-age=3600,public
Server: Jetty(6.1.26.cloudera.4)
<head><meta http-equiv="refresh" content="0;url=/cmf/"></head>
curl -i -u 'admin:admin' http://localhost:7180/api/v1/tools/echo
HTTP/1.1 200 OK
Expires: Thu, 01-Jan-1970 00:00:00 GMT
Set-Cookie: CLOUDERA_MANAGER_SESSIONID=ubst7780j868jkzeysc0a31;Path=/;HttpOnly
Content-Type: application/json
Date: Wed, 28 Mar 2018 18:30:20 GMT
Transfer-Encoding: chunked
Server: Jetty(6.1.26.cloudera.4)
{
"message" : "Hello, World!"
}
both returned an output,
However when trying to access the below url from chrome or fixefox i am getting the below error
http://ip-172-31-44-224.us-west-2.compute.internal:7180
Error :
We can’t connect to the server at ip-172-31-44-224.
If that address is correct, here are three other things you can try:
Any suggestions would be very helpful.
Thanks,
Created 03-27-2018 08:28 PM
Created 03-27-2018 10:00 PM